CVE-2021-21243

CVE-2021-21243

OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, a Kubernetes REST endpoint exposes two methods that deserialize untrusted data from the request body. These endpoints do not enforce any authentication or authorization checks.

This issue may lead to pre-auth RCE.

This issue was fixed in 4.0.3 by not using deserialization at KubernetesResource side.

Source: CVE-2021-21243

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다

Time limit is exhausted. Please reload the CAPTCHA.