CVE-2022-29182

CVE-2022-29182

GoCD is a continuous delivery server. GoCD versions 19.11.0 through 21.4.0 (inclusive) are vulnerable to a Document Object Model (DOM)-based cross-site scripting attack via a pipeline run’s Stage Details > Graphs tab. It is possible for a malicious script on a attacker-hosted site to execute script that will run within the user’s browser context and GoCD session via abuse of a messaging channel used for communication between with the parent page and the stage details graph’s iframe. This could allow an attacker to steal a GoCD user’s session cookies and/or execute malicious code in the user’s context. This issue is fixed in GoCD 22.1.0. There are currently no known workarounds.

Source: CVE-2022-29182

답글 남기기

이메일 주소는 공개되지 않습니다. 필수 항목은 *(으)로 표시합니다

Time limit is exhausted. Please reload the CAPTCHA.